Picproje.org Elektronik Sitesi

DERLEYİCİLER => Diğer Derleyiciler => KEIL => Konuyu başlatan: z - 16 Haziran 2014, 15:50:06

Başlık: Keil - ST-Link problemi
Gönderen: z - 16 Haziran 2014, 15:50:06
Keil 4 kusur versiyondan 5 kusur versiyona terfi ettim. Kirdim.

Debug yapmak istedigimde (ST-Link / V2) ST-Link USB Communication Error mesaji aliyorum.

ST-LINK Utility programi da connect olamiyor. USB kabloyu sokup takarsam connect dersem sorun kalkiyor.

Fakat usb kabloyu sokup takmak Keil'de ise yaramiyor.

Cozumu nedir?
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: muhittin_kaplan - 16 Haziran 2014, 15:56:48
hocam st util in altındaki STLinkUSBDriver.dll dosyasını
C:\Keil\ARM\STLink altına kopyalarmısınız, Bir deneyiniz
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: z - 16 Haziran 2014, 20:35:13
Yok ise yaramadi.

Bir onceki  v4.6 da ST-Link klasorunun icini oldugu gibi v5.1 altindaki klasorun icine atinca duzeldi.
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: engerex - 25 Temmuz 2015, 03:59:57
STLinkUSBDriver.dll ile beraber ST-LINK_CLI.exe adlı dosyayıda kopyalamak gerekiyor. Hatta tek başına ST-LINK_CLI.exe bile yetebilir.

Son sürüm için http://www.st.com/web/en/catalog/tools/PF258168# (http://www.st.com/web/en/catalog/tools/PF258168#) adresinden STSW-LINK004 adlı dosyayı indirip içerisindeki STM32 ST-LINK utility aracını kurun. İçerisinde mevcut.
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: sımışka - 07 Ekim 2017, 01:42:27
Merhaba,
STM32F4 Disco kitte, aynı sorun bende de mevcut şu an. Fakat STM32F411 disco kit ile aynı driver ve programları kullanarak sorun yaşamıyorum. Muhtemelen kitte bir sorun olduğunu düşünüyorum. Kiti usb ile pc ye bağladığımda flash bellek olarak görüyor. Önerilen çözümleri uyguladığım halde düzelme belirtisi göremedim.

Yardımcı olabilir misiniz ?
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: memo333 - 08 Ekim 2017, 02:34:37
sadece bende oluyor sanıyordum. PCyi resetlemek zorunda kalıyorum.
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: enrique_iglesias - 09 Ekim 2017, 05:59:47
aynı durum başıma gelmişti ne yaptıysam olmadı, başka bir nedenden format çektim ilginç bir şekilde çalıştı, sanırım bir önceki versiyon dosyaları ile çakışan bir durum var. Tam emin olmamakla birlikte...
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: apsis - 09 Ekim 2017, 10:17:33
Şuan ben de bağlantı problemi yaşıyorum. Kit üzerindeki usb ışıkları kırmızı da takıldı kaldı. Pc'yi yeniden başlattım nafile. Hem st-link hem de keil "No St-link Detect" uyarısı veriyor.
Matlab ile programlamak için matlab'e eklentiler indirmiştim. Bir etkisi var mı anlayamadım.
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: apsis - 09 Ekim 2017, 10:30:00

(https://s1.postimg.org/7r2ip9leiz/Ekran_Al_nt_s_1234.png) (https://postimg.org/image/7r2ip9leiz/)
ayrıca aygıt yöneticisinde böyle gözüküyor.
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: apsis - 09 Ekim 2017, 11:05:27
St-link'i kaldırıp tekrar yüklediğimde düzeldi.
Başlık: Ynt: Keil - ST-Link problemi
Gönderen: sımışka - 10 Ekim 2017, 00:10:13
Nasıl çalıştırdığımı bilmiyorum fakat şu an program vs atabiliyorum. Eski sürüm firmware yükleyip, yine eski sürüm st link driver&utility kurdum. Belki bundan dolayı düzelmiş olabilir.Ayrıca kitin üzerindeki jumperların varlığından emin olun. ( ST LINK-Discovery jumperları)  Fakat kiti pc ye bağladığımda, @apsis sizdeki gibi ST Link Debug olarak değide , St link dongle ve virtual com port olarak görüyor. Dongle da iken de yine debug yapabiliyorum, problem yok. Fakat dongle'dan tekrar debuga nasıl geçebiliriz acaba ?

Başlık: Ynt: Keil - ST-Link problemi
Gönderen: kimlenbu - 10 Ekim 2017, 02:29:25
Keil 4 (C51) ve Keil 5 (ARM) yüklü bende. Sıkıntıyı bazen yapıyor, aygıt yöneticisini açıp "Evrensel seri veri yolu denetleyicileri" altından st-linki silip, usb kabloyu çıkarıp takınca düzeliyor.