25 Eylül 2018, 01:20:01

Haberler:

Foruma Resim Yükleme ve Boyut Sınırlaması ( ! )  https://bit.ly/2GMFb8H


Keil - ST-Link problemi

Başlatan z, 16 Haziran 2014, 03:50:06

z

Keil 4 kusur versiyondan 5 kusur versiyona terfi ettim. Kirdim.

Debug yapmak istedigimde (ST-Link / V2) ST-Link USB Communication Error mesaji aliyorum.

ST-LINK Utility programi da connect olamiyor. USB kabloyu sokup takarsam connect dersem sorun kalkiyor.

Fakat usb kabloyu sokup takmak Keil'de ise yaramiyor.

Cozumu nedir?

muhittin_kaplan

hocam st util in altındaki STLinkUSBDriver.dll dosyasını
C:\Keil\ARM\STLink altına kopyalarmısınız, Bir deneyiniz

z

16 Haziran 2014, 08:35:13 #2 Son düzenlenme: 16 Haziran 2014, 09:08:26 z
Yok ise yaramadi.

Bir onceki  v4.6 da ST-Link klasorunun icini oldugu gibi v5.1 altindaki klasorun icine atinca duzeldi.

engerex

STLinkUSBDriver.dll ile beraber ST-LINK_CLI.exe adlı dosyayıda kopyalamak gerekiyor. Hatta tek başına ST-LINK_CLI.exe bile yetebilir.

Son sürüm için http://www.st.com/web/en/catalog/tools/PF258168# adresinden STSW-LINK004 adlı dosyayı indirip içerisindeki STM32 ST-LINK utility aracını kurun. İçerisinde mevcut.

sımışka

Merhaba,
STM32F4 Disco kitte, aynı sorun bende de mevcut şu an. Fakat STM32F411 disco kit ile aynı driver ve programları kullanarak sorun yaşamıyorum. Muhtemelen kitte bir sorun olduğunu düşünüyorum. Kiti usb ile pc ye bağladığımda flash bellek olarak görüyor. Önerilen çözümleri uyguladığım halde düzelme belirtisi göremedim.

Yardımcı olabilir misiniz ?

memo333

sadece bende oluyor sanıyordum. PCyi resetlemek zorunda kalıyorum.
stm32f429-disco board uclinux --> https://github.com/vf-tech

enrique_iglesias

aynı durum başıma gelmişti ne yaptıysam olmadı, başka bir nedenden format çektim ilginç bir şekilde çalıştı, sanırım bir önceki versiyon dosyaları ile çakışan bir durum var. Tam emin olmamakla birlikte...

apsis

Şuan ben de bağlantı problemi yaşıyorum. Kit üzerindeki usb ışıkları kırmızı da takıldı kaldı. Pc'yi yeniden başlattım nafile. Hem st-link hem de keil "No St-link Detect" uyarısı veriyor.
Matlab ile programlamak için matlab'e eklentiler indirmiştim. Bir etkisi var mı anlayamadım.
"Makineye Beyin" MEKATRONİK

apsis



ayrıca aygıt yöneticisinde böyle gözüküyor.
"Makineye Beyin" MEKATRONİK

apsis

St-link'i kaldırıp tekrar yüklediğimde düzeldi.
"Makineye Beyin" MEKATRONİK

sımışka

09 Ekim 2017, 12:10:13 #10 Son düzenlenme: 09 Ekim 2017, 12:22:37 sımışka
Nasıl çalıştırdığımı bilmiyorum fakat şu an program vs atabiliyorum. Eski sürüm firmware yükleyip, yine eski sürüm st link driver&utility kurdum. Belki bundan dolayı düzelmiş olabilir.Ayrıca kitin üzerindeki jumperların varlığından emin olun. ( ST LINK-Discovery jumperları)  Fakat kiti pc ye bağladığımda, @apsis sizdeki gibi ST Link Debug olarak değide , St link dongle ve virtual com port olarak görüyor. Dongle da iken de yine debug yapabiliyorum, problem yok. Fakat dongle'dan tekrar debuga nasıl geçebiliriz acaba ?


kimlenbu

Keil 4 (C51) ve Keil 5 (ARM) yüklü bende. Sıkıntıyı bazen yapıyor, aygıt yöneticisini açıp "Evrensel seri veri yolu denetleyicileri" altından st-linki silip, usb kabloyu çıkarıp takınca düzeliyor.

Doodle732

Usb communication hatasi alıyorum yazilim atarken tum jumperlar hersey düzgün 2 farkli bilgisayarda farkli usb kablolarla denedim duzelme olmadi. Driver olarakda suan en gunceli yüklü. st link utility de de ayni hatayi veriyor. Cihazi da yeni aldim ama stlink kismi bozuk olabilir mi ? Nasil bir yol izlemeliyim?