19 Temmuz 2019, 16:39:01

Haberler:

Forum kuralları güncellendi LÜTFEN  okuyunuz:  https://bit.ly/2IjR3ME


Turkce karakter sorunu

Başlatan Zoroaster, 15 Nisan 2017, 07:33:19

Zoroaster

Win7 ve Delphi 6 kullanirken sorunum yoktu ve;

Memoedit1.lines.add('Turkce karakterler iceren text'); de turkce karakterler yazdigim kodda aynen gorunuyordu.

Fakat simdilerde Win10 isletim sistemi ve Delphi7 kullaniyorum ve  yazdigim ğüşı karakterleri yerine gsui karakterleri cikiyor.

Bu sorunu nasil asabilirim?
Seytan deliginden kacti.

Salih

Memo'nun özelliklerinde bulunan karakter türünün,
Türkçe içeren tür olduğuna eminmisin.

Zoroaster

memoedite gelinceye kadar daha s:='Turkçe harflerle oluşturulmuş text';
Komut satırını dahi yazamıyorum. Türkçe harfler delphi editörde çıkmıyor. Fakat bir text bir dosyanın içine girersem Türkçe harflerle yazı yazabiliyorum.

Seytan deliginden kacti.

mur@t

26 Haziran 2019, 19:45:13 #3 Son düzenlenme: 26 Haziran 2019, 19:49:03 mur@t
Alıntı yapılan: Zoroaster - 16 Nisan 2017, 06:12:24memoedite gelinceye kadar daha s:='Turkçe harflerle oluşturulmuş text';
Komut satırını dahi yazamıyorum. Türkçe harfler delphi editörde çıkmıyor. Fakat bir text bir dosyanın içine girersem Türkçe harflerle yazı yazabiliyorum.

Merhaba,
Bu sorunun çözümünü bulabildiniz mi? win7 ve delphi7 ile aynı sorunu yaşıyorum.
Bilgisayarı formatlamadan önce hiç bir sorunum yoktu. (yine win7 kullanıyordum)
Delphi IDE içinde ğ, ı ve ş dışındaki türkçe karakterleri yazabiliyorum. IDE dışında tüm türkçe karakterleri de normal kullanabiliyorum.
ancak IDE içinde ğ ve ş tuşlarına bastığımda g ve s yazıyor. Eski projeyi açtığımda da türkçe karakterler farklı ascii karakter olarak görünüyor.