24 Eylül 2020, 05:50:53

Haberler:

Picproje Pazar Sohbetleri: https://bit.ly/2GHsjAK


Stm32f103 kod yükleme

Başlatan saban88, 11 Haziran 2020, 14:06:17

saban88

yaptığım bağlantı en basitinden aşağıdaki gibi. blue pillde zaten gerekli bağlantılar var.bir eksik var mı diye multimetre ile kontrol ettim. artık kendimden şüphe etmeye başladım.  :du:


saban88

geliştirme yaparken sys den debug ı single wire şeklinde ayarladım. bu şekilde geliştirme esnasında bi sorun yaşamadım. fakat alınan sıfır çipler de bu ayar yapılmamış olacak. bu yüzden bu araştırmaya girdim. bilgi olarak bunuda yazmak istedim.

z

Ciplerde SWD diye bir ayar yapilmiyor.

StLink cihazini yazilim senin tanimlamana gore ya Jtag yada SWD uzerinden kullaniyor.
Keil'de debug ayarlarinda swd mi yoksa jtag mi kullanacagini tanimliyorsun. STlinkte de ayni ayar var.

Eger yazdigin program SWD/jtag pinlerini baska amaclar icin tanimliyorsa programi bir kere cipe yazdinmi artik o pinler program calisir calismaz alikonulacagi icin swd Jtag programlamada sorun yasarsin. Bu durumda yapilacak sey cipi hard reset atarak programlamaktir.

Sunu da dene. STlink ile cipi komple sil. Normal reset ayarini yap. Cipi resetlemeden programlamayi dene.
Yada cipe kendi yazdigin bir programi degil bir baska programi atmayi dene.




saban88

bahsettiğim kısım burası.tuhaf şeyler oldu kafam karıştı biraz. Dediğiniz gibi chipe stlinkten bağlanıp full erase ettim. sonrasında stlinkten rahatca connect oldu. fakat stmcube ide den debug kısmı no debug seçip yükleme yaparsam sonraki bağlantılarda hardware reset gerekiyor. Sebebini anlamadım ama kendimce bi çözüm oldu. Full erase yaptığımda fabrika çıkışına dönüyorsa bağlandığımda herhangibir sorun olmuyor. ilk yüklemede ise debug kısmında serial wire seçerek bu sorundan kurtulmuş oldum.


RaMu

Alıntı yapılan: saban88 - 15 Haziran 2020, 17:32:49... fakat stmcube ide den debug kısmı no debug seçip yükleme yaparsam sonraki bağlantılarda hardware reset gerekiyor.
...

Tuhaf bir şey yok.
No debug deyip programlama bacakları yok, ben kullanacağım onları demiş oluyorsun.
Mcu enerjilenince bu bacaklara bakıp programlayıcı takılımı kontrol etmiyor veya
enerjiliyken programlama bacaklarından programlama ile ilgili sinyaller gelsede umursamıyor.
Bu halde bile reset pinine basılı olarak programlamaya başlarsan
mcu programlama bacaklarına bakar ve programlayıcı program yükleyecekse yükleyebilir.

Alıntı yapılan: saban88 - 15 Haziran 2020, 17:32:49... ilk yüklemede ise debug kısmında serial wire seçerek bu sorundan kurtulmuş oldum.
...

Kendin problem çıkarıp olması gerektiği gibi yapıp çözdüm diyorsun.
Çipe program yüklerken
daha sonrada program yükleyeceksen
hangi bacaklardan ne yöntemle programlama yapacağını yüklediğin kodda belirteceksin.
İşte bu debug kısmında serial wire seçmek bir yolu,
Swdio Swclk pinlerini programlama pinleri olarak kullanacağım demiş oluyorsun.

Aynıları yazılmış zaten önceki mesajlarda.
Sorularınıza hızlı cevap alın: http://www.picproje.org/index.php/topic,57135.0.html

saban88

Alıntı yapılan: RaMu - 15 Haziran 2020, 18:42:45Tuhaf bir şey yok.
No debug deyip programlama bacakları yok, ben kullanacağım onları demiş oluyorsun.
Mcu enerjilenince bu bacaklara bakıp programlayıcı takılımı kontrol etmiyor veya
enerjiliyken programlama bacaklarından programlama ile ilgili sinyaller gelsede umursamıyor.
Bu halde bile reset pinine basılı olarak programlamaya başlarsan
mcu programlama bacaklarına bakar ve programlayıcı program yükleyecekse yükleyebilir.
Kendin problem çıkarıp olması gerektiği gibi yapıp çözdüm diyorsun.
Çipe program yüklerken
daha sonrada program yükleyeceksen
hangi bacaklardan ne yöntemle programlama yapacağını yüklediğin kodda belirteceksin.
İşte bu debug kısmında serial wire seçmek bir yolu,
Swdio Swclk pinlerini programlama pinleri olarak kullanacağım demiş oluyorsun.

Aynıları yazılmış zaten önceki mesajlarda.


hacı abi verdiğin bilgiler için sağol ama yanında olsam temiz sopanı yerdim galiba. Bunları bilsem zaten sormam. Problemi çıkardığımın farkında değilim. Tırmalayarak öğreniyorum. Yardımlarınız için @RaMu ve @z teşekkürler.

RaMu

Alıntı yapılan: saban88 - 15 Haziran 2020, 19:16:58hacı abi verdiğin bilgiler için sağol ama yanında olsam temiz sopanı yerdim galiba. Bunları bilsem zaten sormam. Problemi çıkardığımın farkında değilim. Tırmalayarak öğreniyorum. Yardımlarınız için @RaMu ve @z teşekkürler.
Yok hacım ne sopası öyle zulumler bizde yok.
Bizde aynı tırmanışlardan geçtik,
@z nin trt spikeri ahengiyle anlatımından anlaşılmayınca
birde halk ağzı ile anlatayım dedim.
Sorularınıza hızlı cevap alın: http://www.picproje.org/index.php/topic,57135.0.html

magnetron

merhaba forum,

yeni konu açmiyim dedim

bu aşağıdaki hata nerden kaynaklanır ?

orijinal st-link v2 SWD bacaklarını blue pill e bağladım
blue pill orijinalindeki blink led çalışıyor (yani canlı)

st-link in ışığı sabit kırmızı yanıyor driveri aygıt yöneticisinde çalışıyor gözüküyor

https://i.imgyukle.com/2020/09/07/xXWynv.png

magnetron

11 Eylül 2020, 00:03:03 #23 Son düzenlenme: 11 Eylül 2020, 00:23:37 magnetron
blue pill in 3.3 voltu ST-Link in VCC ucuna bağlayınca işlemciye program atabildim

attım ama CUBEIDE den start butona basınca uC çalışmaya başlıyor
ama SWD bağlantısı kopuyor breakpointlerde durmuyor
 ( basit LED blink uygulaması - compile de debug seçili )

aşağı resimdeki mesajı veriyor - SWD hızını dibine kadar düşürdüm gene aynı

neden olabilir ? teşekkür

https://i.imgyukle.com/2020/09/09/xmXyBs.png

a.zorba

reset baglımı . degilse baglayıp reset ayarını connet under reset ile deneyebilirmisin.
İçinizdeki düşmanlık yakıp yıkmayı hoşgörüyorsa yerine koyacağınız sistemin özgürlük olacağını mı düşünüyorsunuz?