Beaglebone Black ile QT üzerinde gui uygulaması yapan var mı?

Başlatan Erhan YILMAZ, 06 Ocak 2015, 19:31:30

Erhan YILMAZ

Konu başlığından da anlaşılacağı gibi BBB üzerinde gui uygulamaları yapmaya çalışıyorum. 7 inç dokunmatik ekran kullanıyorum.
BBB üzerinde angstrom yüklü host makinede(virtual machine) ise ubuntu yüklü. Derek molloy'un QT ile ilgili videosunu izledim fakat bir türlü sonuca varamadım.

Öncelikle qt'yi host makineye kurdum. Gerekli qt arm toolchainini buldum indirdim. www.angstrom-distribution.org kapandığı için toolchaini birileri google drive'a upload etmiş ordan indirdim. Fakat BBB için gerekli qt4-embedded dosyalarını yükleyemedim. Sunucudan çekemiyor hata verdi. İnternette araştırdım fakat çözüme ulaşamadım.

Neyse zaten kodu derleyemediğim için qt4'ün çok üstüne düşmedim. Qt'yi kurdum host makineye yeni proje oluşturup kit ayarlarını vs. yaptım. Fakat unexpected newline gibi bilinen bir hata aldım. Bunu da araştırınca kit(derleyici, debugger, make) ayarlarından olabileceğini öğrendim. Onları da denedim ama sonuca ulaşamadım. Açıkçası çok çektirdi. Daha zaten kodu derlesem muhtemelen BBB içinde çalışmayacak çünkü qt4-embedded dosyalarını da yükleyemedim. Qt'yi boşver dedim python ile bir şeyler yapayım dedim. Bu seferde python gui kütüphanesi tkinter'i BBB'ye yükleyemedim.

Sonuç olarak saç baş yoldurttu. İndirdiğim toolchainden de emin olamadığım için kit ayarlarının doğru olup olmadığını bilemiyorum. Birkaç birşey daha deneyeceğim olmadı BBB içine ubuntu yada android kuracağım. Başka şeyler deneyeceğim.

Son olarak birde sizlere sorayıp dedim. Bu aşamaları geçip BBB üzerinde gui(özellikle QT ile) uygulaması çalıştıran arkadaşlar var mı? Varsa yardımcı olurlarsa sevinirim. Host olarak ne kullandınız? Hangi QT versiyonu? Hangi angstrom versiyonu gibi soruların cevabına ihtiyacım var.
Waiting for humanity to compile the AI code that will kill humanity!


Erhan YILMAZ

Teşekkürler hocam okudum şimdi deneyeceğim fakat beaglebona qt4-embedded gibi bir kütüphane yüklenmesi gerekmiyor mu? Birde black içinde aynı işlemler geçerli mi?

mesaj birleştirme:: 06 Ocak 2015, 20:09:03

Yazıda CodeBench Lite 2012.03-57 bunu indirin çıkartın demişsiniz ama bin dosyası olarak iniyor bende. Çıkarmaya gerek yok herhalde?
Waiting for humanity to compile the AI code that will kill humanity!

yamak

Hocam o yazı biraz eski bazı değişiklikler olmuş olabilir.Qt kütüphaneleri derledeğiniz opt dizininde oluşan klasörün aynısını beaglebone black üzerindeki opt dizinine kopyalamanız gerekmektedir.Bir de illaki o cross compiler ı kullanmanız gerekmez.Herhangi bir cross compiler da olabilir

Erhan YILMAZ

Hocam şimdi fark ettimde bende zaten make dosyası varmış İndirdiğim toolchainin içinde. Fakat projeler ayarlarına bakınca şimdi fark ettim ABI detection failed gibi hata vermiş. Sorun burada galiba.

Waiting for humanity to compile the AI code that will kill humanity!

Yasal Uyarı: Picproje.org sitemizde 5651 sayılı kanunun 8. maddesine ve T.C.Knın 125. maddesine göre tüm üyelerimiz yaptıkları paylaşımlardan kendileri sorumludur. Picproje.org hakkında yapılacak tüm hukuksal şikayetleri İletişim sayfamızdan bize bildirdikten en geç 3 (üç) iş günü içerisinde ilgili kanunlar ve yönetmelikler çerçevesinde tarafımızca incelenerek gereken işlemler yapılacak ve site yöneticilerimiz tarafından bilgi verilecektir.