St Link V2 Dongle No St link detected hatası

Başlatan Kırambor, 10 Ocak 2022, 19:17:48

Kırambor

İyi günler. Elimde STM32F103C8T6 mikroişlemci bulunan bir geliştirme kartı var. Fakat bu kartta ST Link yok. Bu yüzden ST Link V2 Dongle satın aldım. Bağlantıları şu şekilde yaptım.

ST Link- Kit
SWDIO -> DIO
SWCLK -> CLK
GND   -> GND
3.3V -> 3.3V

ST Link Utility programından cihaza bağlan dediğimde bağlantı gerçekleşiyor. Hatta cihaz ID'si şu şekilde "ST-LINK SN : 350053000A0000523247504E". Sürümü de "V2J39S7".

Basit bir kod yazıp debug etmek istiyorum. Fakat No ST LINK Detected hatası alıyorum.

Elimdeki kit, stlink ve debug ayarlarım fotoğraflarda.

Bu hatayı nasıl çözebilirim?








Tagli

ST-LINK S/N önündeki işareti kaldırmayı bir dene. Normalde orada bir seçim yapmana ve seri numarasının girili olmasına gerek yok. Sadece SWD'nin seçili olması yeterli.

Bu arada bildiğim kadarıyla ST Link Utility eski bir program. Bunun yerine daha güncel olan STM32CubeProgrammer kullanman bence daha iyi olur. Aynı sorunun orada çıkıp çıkmadığını da bir denemiş olursun.
Gökçe Tağlıoğlu

Kırambor

Alıntı yapılan: Tagli - 10 Ocak 2022, 19:28:24ST-LINK S/N önündeki işareti kaldırmayı bir dene. Normalde orada bir seçim yapmana ve seri numarasının girili olmasına gerek yok. Sadece SWD'nin seçili olması yeterli.

Bu arada bildiğim kadarıyla ST Link Utility eski bir program. Bunun yerine daha güncel olan STM32CubeProgrammer kullanman bence daha iyi olur. Aynı sorunun orada çıkıp çıkmadığını da bir denemiş olursun.

Seri numarasını kaldırdım fakat bu sefer de "Could not verify st link device" hatası alıyorum. STM32CubeProgrammer'ı da kurdum fakat 7.adımdan itibaren öteye gidemiyorum. Youtube'da bir videoda benim gibi bu hatayı alanlar gördüm ama internette şu ana kadar bu hatayı nasıl çözeceğime dair bir kaynak bulamadım.





Tagli

Programın daha kurulum aşamasında hata vermesi - daha doğrusu takılması - çok sıra dışı bir durum. Bence başka bir sorun var.

Aklıma gelen birkaç ihtimal (sadece sesli düşünüyorum, alakasız da olabilir)
1) Klon ST-Link'te bir arıza
2) Bilgisayarda Java kurulumu ile ilgili bir sorun
3) Kurulum veya dosya yollarında Türkçe karakter veya boşluk
4) Windows'ta dil ayarları veya lokalizasyon ile ilgili bir sorun.
Gökçe Tağlıoğlu

mfurkanuyar

Selamlar,

Programlayıcı üzerinde bulunan Vtarget pini ile 3.3V pinini kısa devre yapıp deneyebilir misin?

St link utility --> settings kısmından module başlığı altındaki yeri de "hot plug" yaptığında Target voltajı 3.3V yazıyor mu kontrol eder misin?

mfurkanuyar

Connection settings kısmı: SWD olmasına da dikkat et lütfen :)

Yasal Uyarı: Picproje.org sitemizde 5651 sayılı kanunun 8. maddesine ve T.C.Knın 125. maddesine göre tüm üyelerimiz yaptıkları paylaşımlardan kendileri sorumludur. Picproje.org hakkında yapılacak tüm hukuksal şikayetleri İletişim sayfamızdan bize bildirdikten en geç 3 (üç) iş günü içerisinde ilgili kanunlar ve yönetmelikler çerçevesinde tarafımızca incelenerek gereken işlemler yapılacak ve site yöneticilerimiz tarafından bilgi verilecektir.